A4988 Schrittmotor-Treiber: Keine 5 V auf VDD

StartHardware-Forum A4988 Schrittmotor-Treiber: Keine 5 V auf VDD

Schlagwörter: 

Ansicht von 6 Beiträgen - 1 bis 6 (von insgesamt 6)
  • Autor
    Beiträge
  • #7449
    cyberbob00
    Teilnehmer

    Hi Leute!

    Bin nicht ganz neu im Atmel-/Arduino-Geschäft. Habe anfangs diverse Atmels noch “zu Fuß” programmiert, allerdings machen’s einem die Arduinos doch einfacher.

    Habe bei einem aktuellen Projekt ein dickes Brett vorm Kopf, für die Experten hier wahrscheinlich ein Klacks, dieses zu entfernen:

    Verwende für einen Nema17-Schrittmotor einen A4988-Treiber (baue einen Drehtisch für Photogrammetrie). Auf der A4988-Treiberplatine gibt es einen 5 V-Anschluss (VDD). Wenn ich die Platine bei Vmot mit 12 V betreibe, müssen dann nicht auf dem VDD-Anschluss 5 V anliegen?

    Bei mir sind es schön 0 V, meine Logik dahinter (einschließlich Arduino Nano) bekommt also keine Versorgung und springt nicht an.

    Wo ist jetzt der (Denk-)Fehler? Wie bekomme ich vom A988-Treiber auf VDD die 5 V für meine Logik? Bin für jeden Klapps auf den Hinterkopf dankbar! :-)

    Viele Grüße!

    #7451
    Franz-Peter
    Teilnehmer

    Der Vdd Anschluß am A4988 ist kein 5V Ausgang zur Versorgung anderer Logik. Vielmehr ist es der 5V Versorgungsanschluß der internen Logik.
    Du kannst da also keine 5V abzapfen, vielmehr musst Du dort 5V anlegen, um die interne Logik des A4988 zu betreiben.

    • Diese Antwort wurde geändert vor 1 Monat, 3 Wochen von Franz-Peter.
    #7453
    cyberbob00
    Teilnehmer

    Ach! Sieh an!

    Habe in einem Datenblatt was von “5VOUT” gelesen. Entweder war ich im falschen Datenblatt, oder die Info war schlicht falsch.

    Hätte ich ja noch lange rumprobieren können. Jetzt weiß ich wenigsten, wie ich weiter komme.

    Jedenfalls herzlichen Dank für den Hinweis! :-)

    Schönes Wochenende!

    #7460
    cyberbob00
    Teilnehmer

    Kurzes Update: Habe jetzt einen 7805 Spannungsregler eingebaut, um aus den 12 V, die vom Netzteil an Vmot gehen, noch 5 V zu erzeugen. Diese in den 5 V-Ast der Schaltung (und natürlich den A4988 in Vdd) eingespeist und siehe da: Es läuft! Das Thema ist also erledigt.

    Nochmals Danke für den Hinweis!

    #7461
    cyberbob00
    Teilnehmer

    Kurzes Update: Habe jetzt einen 7805 Spannungsregler eingebaut, um aus den 12 V, die vom Netzteil an Vmot gehen, noch 5 V zu erzeugen. Diese in den 5 V-Ast der Schaltung (und natürlich Vdd des A4988) eingespeist und siehe da: Es läuft! Das Thema ist also erledigt.

    Nochmals Danke für den Hinweis!

    #7462
    Stefan Hermann
    Verwalter

    Super, dass ihr es hin bekommen habt. Ich hatte hier mal was dazu geschrieben. Ich denke mal, dass deine Schaltung jetzt so ähnlich aussieht, oder? https://starthardware.org/arduino-a4988-nema17/

    Liebe Grüße

    Stefan

Ansicht von 6 Beiträgen - 1 bis 6 (von insgesamt 6)
  • Du musst angemeldet sein, um auf dieses Thema antworten zu können.