Piezo-Musik

  • Dieses Thema hat 7 Antworten und 1 Teilnehmer, und wurde zuletzt aktualisiert vor 3 Monaten von Nicole Halanek.
Ansicht von 8 Beiträgen - 1 bis 8 (von insgesamt 8)
  • Autor
    Beiträge
  • #8662 Antworten
    Nicole Halanek
    Gast

    Liebes Forum, lieber Stefan,

    wiedermal ich mit Anfaengerfragen, ich hoffe, das ist ok.

    In deinem Anfaengertutorial hast du die Uebungen mit den Toenen. Daran bin ich ja ganz am Anfang gescheitert, weil ich keine unterschiedlichen Toene bekommen habe. Diesmal habe ich mir eine Sammlung diverser Lautsprecher organisiert bzw. aus irgendwas ausgeloetet. Ich habe 5 verschiedene solcher Dinger aufs Board gesteckt, mit jeweils zwei Kabeln versehen, alle schwarzen Kabeln in die Minusleiste gesteckt und diese mit GND verbunden, und alle anderen bunt mit verschiedenen Pins, 9, 10, 11, und 13. Den einen konnte ich mir schenken, der hat keinen Ton ausgeworfen. Vielleicht habe ich ihn ruiniert. Es war einer, wie sie in den Grusskarten sind, ein Ring mit einer Scheibe in der Mitte. Ein Kabel war drangeloetet, innen auf der Scheibe, das andere Kabel habe ich drangeloetet, vielleicht war das falsch. Das war die erste Frage.

    Ansonsten hat das mit der Melodie ganz gut geklappt. Der eine, mit dem ich damals gescheitert bin, ist wirklcih so schlecht. Wenn man den Kleber entfernt, kommt zwar ein bisschen was an verschiedenen Toenen raus, aber nicht wirklich merklich.
    Zweite Frage: Die Frequenz sollte doch immer die gleiche Tonhoehe ergeben (Stichwort Kammerton…). Tuts aber nicht, jeder Lautsprecher hat seine eigene spezifische Tonhoehe bei allen Frequenzen. Ist vielleicht auch nicht unlogisch. Was ist deine Erklaerung bzw. Abhilfe dazu?

    Dritte Frage: Offenbar war meine Schaltung zu simplistisch gedacht. Als mich das Gedusel genervt hat, hab ich den GND-Stecker gezogen. Nichts ist passiert, das Gedusel ging weiter. Ich musste jeweils den richtigen Schwarzen Draht ziehen. Hab ich irgendwo einen Kurzschluss verursacht? Wieso ist der Stromfluss bei allen angesprochenen Lautsprechern normal weitergegangen, obwohl sie eigentich keine Verbindung zum GND hatten?

    Und daraus ergibt sich bereits Frage vier: Ich habe beim Anschliessen der Piezos auf die Polung geachtet, es hat sich aber sehr schnell herausgestellt, dass die bei allen vier verschiedenen Lautsprechern egal war. Woran liegt das, an der Schaltung kann es nicht liegen, weil ich sie auch einzeln ausprobiert habe.

    lg
    niki

    #8675 Antworten
    Stefan Hermann
    Verwalter

    Hi Niki,

    schön von dir zu lesen. Ein gesundes neues Jahr wünsche ich dir. Da hast du ja eine Versuchsreihe hinter dir. Super! Experimentieren macht Spaß. :-)

    Also ich bin ja weder Elektroniker, noch Physiker. Ich kann also nur vermuten, dass jeder Lautsprecher spezifische Eigenschaften hat. Wie bei einem Musikinstrument ist die Beschaffenheit sicherlich ausschlaggebend und in der Herstellung wird es auch Unterschiede z. B. in der Materialdicke etc. geben.

    Der Grußkarten-Lautsprecher ist bestimmt ein Piezo. Ich hab vor Jahren mal was darüber geschrieben. Da gibt es noch ein Bild dazu: https://starthardware.org/piezo-element/ Vielleicht hat der beim Löten zu viel Hitze abbekommen.

    Das mit dem Stromfluss bei abgezogenem GND kann ich mir nicht genau erklären. Dazu müsste ich noch mal den Schaltplan sehen. Vielleicht hat noch jemand anderes im Forum eine Idee.

    Die Polung ist glaube ich nur bei aktiven Transducern wichtig, da sie eine integrierte Halbleiter-Verstärkung verwenden. Ansonsten kann man die Kabel auch vertauschen.

    Ich hoffe, das hilft dir ein bisschen weiter. Was hast du mit den ganzen Lautsprechern vor? Hast du schon ein Projekt im Kopf?

    Liebe Grüße

    Stefan

    #8676 Antworten
    Nicole Halanek
    Gast

    Hallo Stefan!

    Danke fuer deine Antworten!
    Die Schaltung war wie gesagt ganz einfach. Jeder Lautsprecher einmal zum Minuspol einmal zu einem Pin mit Tilde (weiss nicht, ob die Tilde notwendig war, hab das mit dem PWM noch nicht ganz verstanden). Dann den Minuspol mit einem gemeinsamen Kabel zum GND. Vielleicht ist diese Parallelschaltung irgendwie in sich verbunden und schliesst den Stromkreis irgendwie?
    Oh, ich dachte, du bist irgendeine Art Mechatroniker, wenn du dich so gut auskennst.

    Ich hab damit gar kein besonderes Projekt vor. Mein einziges Projekt im Moment ist ein bisschen diese Programmiersprache zu lernen, Ideen zu sammeln, rumzuspielen und alle moeglichen Kleinprojekte auszuprobieren. Irgendwann wird sich dann schon was auftun, wozu ich das alles brauchen kann :-) Ein Projekt habe ich schon im Hinterkopf, aber ich moechte erstmal bisschen die Hintergruende verstehen.

    lg
    niki

    #8677 Antworten
    Stefan Hermann
    Verwalter

    Hi Niki,

    hehe. Naja, die Fragen, wieso die Frequenz in den Lautsprechern unterschiedliche Töne erzeugt, wäre halt eher was für einen Physiker und der immer noch erklingende Ton trotz unterbrochenem GND ist auch schon ein ziemlich spezielles Problem. Ich hab Interaction-Design studiert und arbeite sein 2007 mit Arduino. Ich hab lange für Fritzing gearbeitet und dutzende Arduino-Workshops gegeben. Und in meinem professionellen Leben kümmere ich mich als Produktmanager um IoT-Produkte und Technologie. Von daher kenne ich mich schon ein bisschen aus, aber eine Antwort auf diese Frage habe ich nicht. Ich habe zwei Theorien:

    1: Irgendwo hat noch eine zweite Verbindung zum GND existiert.
    2: Vielleicht gibt es in den Speakern eine Art Lade-Entladevorgang, ähnlich eines Kondensators, die eine Zeit lang auch mit nur einem Kabel funktioniert.
    3: (Ja, die ist Bonus :-D ) Die Schaltung zwischen den Speakern hat (min.) zwei digitale Pins des Arduinos so verbunden, so dass ein Stromkreis dazwischen verbunden wurde.

    Ist aber alles geraten. Hast du die Schaltung noch aufgebaut? Willst du mir mal ein Foto schicken? (Geht leider nicht über das Forum.)

    Liebe Grüße

    Stefan

    #8678 Antworten
    Nicole Halanek
    Gast

    Hallo Stefan!

    Danke fuer die ausfuehrliche Antwort!
    Ist ja superinteressant, was du so machst.

    Ich hab versucht, ein Foto zu machen, ich bin da nicht sehr gut und hab nicht alles gleichzeitig scharf bekommen. Der Arduino selber ist jetzt fuers Foto abgesteckt. Ich tippe auf 1) oder 3) bei deinen Vermutungen. Ich habe von Anfang an 1) vermutet und befuerchtet, aber nichts gefunden. Mit 3) kenne ich mich nicht aus.
    https://web.tresorit.com/l/YH1RA#flDGAUl-NYHV3QgLZBrGvQ

    Das mit den verschiedenen Frequenzen ist wohl eine Kalibrationssache fuer Musiktuner oder elektronische Instrumente. Offenbar hat nicht alles mit der gleichen Frequenz auch den gleichen Ton :-)

    lg
    niki

    #8679 Antworten
    Franz-Peter
    Gast

    Hallo Niki,
    da wird deine gemeinsame Masse das Problem sein. Wenn Du die von Gns abziehst, kann noch Strom von einem Arduino-Pin über 2 Lautsprecher ( die über deine gemeinsame -Leiste ja noch verbunden sind ) zu einem anderen Arduino Pin fliessen. Wenn Du den Lautsprecher sicher abschalten willst, musst Du direkt das Kabel vom LS abstecken.

    Es gibt von diesen kleinen schwarzen Piezos auch Ausführungen, die aktiv einen Ton erzeugen, sobald Spannung anliegt. Die kannst Du für deine Zwecke nicht verwenden, denn die erzeugen dann immer den gleichen Ton.

    lg
    Franz-Peter

    #8680 Antworten
    Stefan Hermann
    Verwalter

    Hi ihr beiden,

    ich glaube Franz-Peter hat recht. Der Strom sucht sich einfach einen Weg von dem einen Pin zum anderen. Bei den Pins ist es ja so: Wenn du sie HIGH schaltest, liegt 5V+ an, wenn du sie LOW schaltest, liegt GND an. Der tone()-Befehl erzeugt ja eine Frequenz durchs schnelle HIGH- und LOW-Schalten. Und das sollte den Effekt erklären, den du beschreibst.

    Danke Franz-Peter für die Antwort (Gesundes neues Jahr übrigens :-) ) und Niki für die spannenden Fragen!

    Liebe Grüße

    Stefan

    #8681 Antworten
    Nicole Halanek
    Gast

    Hallo Peter und Stefan!

    Ahja, so gesehen ist das ja eigentlich ganz logisch. Die 5 V liegen ja immer nur da, wo gerade ein Ton rauskommt.Allerdings sollte der Rest ja vom Stromkreis ausgekoppelt sein. Naja die Logik der Physik hab ich noch nie wirklich verstanden, ich bin Chemikerin, da ist alles logisch und verstaendlich ;-)

    Dieser mit dem schiachen Ton sollte eigentlich ein passiver sein, wenn es das ist, was du meinst. Er hat jedenfalls keine sichtbare Platine und war als passive buzzer bezeichnet. Aber es waere eine Erklaerung.

    Danke! Dann ist das Thema fuer mich momentan beantwortet und erledigt!

    lg
    niki

Ansicht von 8 Beiträgen - 1 bis 8 (von insgesamt 8)
Antwort auf: Piezo-Musik
Deine Information: